homepage Welcome to WebmasterWorld Guest from 107.20.25.215
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member
Home / Forums Index / WebmasterWorld / Webmaster General
Forum Library, Charter, Moderators: phranque & physics

Webmaster General Forum

    
FTP not working on either PC
Can access server, but not upload files: advice?
Sorry In Advance




msg:360619
 7:34 am on Aug 1, 2005 (gmt 0)

I wonder if anyone can help me with my FTP problem?

I've got two separate PCs (XP home, XP pro), both plugged into the same Netgear DG834 'wired' broadband router. On one PC, I've got WS_FTPpro installed, and the other has two different freebie FTP programmes installed (the most recent one just yesterday). Problem is, I can't seem to upload files to any of my servers (whether free ones or paid) any more! This has been happening for at least a couple of months.

I can access the server, and I can navigate through folders and delete files, but when I try to upload an mp3 or other large-ish file to any folder, it attempts the transfer, then times out. It transfers only the file name, with a size of 0kb to the server.

Could this be related to my modem settings, or is it my firewall, maybe? I've tried it with the XPSP2 firewall switched off, as well, to no avail.

I've also got a kind of proxy software which reports all internet usage to a remote site as the PCs have multiple users. That software's site FAQs didn't imply any issues with FTP software, though.

On one of the FTP apps I was able to upload smaller files like web pages, although that was temperamental, and sometimes I had to try it once, then shut it down, then try it again. Which is obviously a royal PITA.

Anyone shed any light on this? Please be aware that I'm not an expert (you guessed that already, huh!) in any of this stuff!

 

Sorry In Advance




msg:360620
 10:44 am on Aug 1, 2005 (gmt 0)

additionally, it's nothing to do with whether the FTP programme is set to "active" or "passive". Anyone able to offer a suggestion here?

trillianjedi




msg:360621
 10:48 am on Aug 1, 2005 (gmt 0)

Sounds to me like you've got some ports blocked.

FTP works on port 21 for signalling (which sounds like it's working fine) then additional ports for the actual data transfer.

Sounds to me like it's the actual data transfer ports that are not being let through.

Have you got all ports other than 21, 80, 25 etc blocked in the firewall possibly? Are you running any local personal firewalls on the PC that need to be told to allow connections to the FTP apps?

Passive mode tells the server to choose which ports it wants. It's generally the most reliable (I find that to be the case anyway).

TJ

Sorry In Advance




msg:360622
 11:49 am on Aug 16, 2005 (gmt 0)

Hi TJ. Thanks for your reply, and sorry for the delay: I just haven't had time to look into the problem until now!

============
-"Have you got all ports other than 21, 80, 25 etc blocked in the firewall possibly?"-
===================
I don't know. How would I check this? I have two firewalls: one in my router, one which is software based (the standard windows XP SP2 firewall)

In my Netgear DG834 Firewall Router I have the following areas that can be configured:

Basic Setup
Basic Settings
ADSL Settings
Security
Logs
Block Sites
Firewall Rules
Services
Schedule
E-mail
Maintenance
Router Status
Attached Devices
Backup Settings
Set Password
Diagnostics
Router Upgrade
Advanced
WAN Setup
Dynamic DNS
LAN IP Setup
Remote Management
Static Routes
UPnP

Do you know which of these I should attempt to change/look into to check settings?
====================
-"Are you running any local personal firewalls on the PC that need to be told to allow connections to the FTP apps?"-
====================
I am running windows XP SP2 firewall, but no others. In it's control panel, it indicates that my FTP applications are amongst those which are allowed internet access. This gives me the option of "add port". Should I try this? What number should I enter in here?

When I disable windows firewall, it doesn't make the problem go away, which makes me suspect the hardware modem. Any thoughts? Help is much appreciated!

Angelis




msg:360623
 12:02 pm on Aug 16, 2005 (gmt 0)

Check the firewall rules on your router, my home network blocks it on every connected machine by default...

Sorry In Advance




msg:360624
 12:33 pm on Aug 16, 2005 (gmt 0)

My Firewall Rules Page looks like this:

Outbound Services:

#: ................ Default
Enable:............ Yes
Service Name:...... Any
Action:............ ALLOW Always
LAN Users: ........ Any
WAN Servers:....... Any
Log: .............. Never

Inbound Services:

#: ................ Default
Enable:............ Yes
Service Name:...... Any
Action:............ BLOCK Always
LAN Users: ........ Any
WAN Servers:....... Any
Log: .............. Never

With the option to
[Add]---[Edit]---[Move]---[Delete]

under both Outbound and Inbound services.

When I click "Add" I get to a page offering the following

Service: ........... Drop down box (default "Any(ALL)" )
Action: ............ Drop down box (default "ALLOW always")

Send to LAN server ... [__][__][__][__]

WAN Users: ........... Drop down box (options= "Any"/"Single Address"/"Address Range")

start: ........: [__][__][__][__]
finish ........: [__][__][__][__]

Is this where I might change the settings?
You may have guessed this is all double dutch to me!
thanks

Sorry In Advance




msg:360625
 7:02 pm on Aug 16, 2005 (gmt 0)

Well, it has turned out to be simpler than I realised: the server was full, so I was being stopped from uploading any more files. The other server I had tried it on also prevents users from uploading anything but HTML (small print somewhere!). Thanks for your help, though: was much appreciated!

Sorry In Advance




msg:360626
 3:09 pm on Aug 17, 2005 (gmt 0)

actually, scratch that last post. It's stopped working again, and the admin for the server space are saying that they've managed to use the space without any problems. How strange.

I assumed it was the case that I required more space on the server because it worked briefly after I deleted some files from the server. It has since stopped working again, and I've not uploaded anything else.

Sorry In Advance




msg:360627
 9:24 am on Aug 18, 2005 (gmt 0)

Just for posterity, I have got the problem solved. It relates to my DG834 router and windows XP SP2 updates.

I installed the firmware update from the Netgear site, and now all uploads are happily chugging away. (don't you love that phrase "make sure you have the latest drivers")

For anyone else having this problem,you can see the full discussion of it at the
soundonsound .com forum,

go to the PC music forum

and search for topic title

"My FTP programmes don't work on either PC!"

I don't think I'm allowed to link it in this forum, sorry.

That forum thread will point you towards a thread called "problems uploading" on the Smart FTP forum, which has more people encountering the same issue.

Thanks

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / WebmasterWorld / Webmaster General
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved