homepage Welcome to WebmasterWorld Guest from 54.161.147.106
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / WebmasterWorld / Webmaster General
Forum Library, Charter, Moderators: phranque

Webmaster General Forum

    
HELP! Anyone know how to config paths?
"Full system path" and "WWW path". I've tried everything without success...
Dan_Titan




msg:362067
 5:02 pm on Sep 16, 2001 (gmt 0)

Hi,
I'm a freshmen doing stuff that are way above my head.
Have a message board from cgi-factory ( [cgi-factory.com...] ) I'm trying to set up. All is (probably) going well, unless from the boxes in the config where they ask me to write some paths. I've tried every possible path but it still doesn't work.
If there's some kind hearted soul out there with a few minutes to spare and insight about this, mail me and I'll mail you all the details plus screen shots.
I'm about to have a break-down....

 

Brett_Tabke




msg:362068
 5:13 pm on Sep 16, 2001 (gmt 0)

Well, start with the path as you know it.

Do you have telnet access? Move to the directory with the cgi in it.

echo $PWD

That will tell you the current directory. Or look in the directory location of your ftp client. That should be the server "path".

Macguru




msg:362069
 5:16 pm on Sep 16, 2001 (gmt 0)

Hi Dan_Titan,

I am sure there is a lot people in here willing to help you. But the private way is not recommended since all could benefit from the answers.

If I get you well you have difficulties installing a PERL script to a remote server and the configuring requires you a full path of server.

questions.

What server platform is it? (windows or UNIX?)
Do you have acess to error log files?

Till I hear from you

Slade




msg:362070
 5:21 pm on Sep 16, 2001 (gmt 0)

If your system has PHP set up on it, this little script should shine some light on your problem...

<html>
<?php phpinfo() ?>
</html>

Save it(somescript.php), upload it, and open it in your browser, and print it out...

Dan_Titan




msg:362071
 5:35 pm on Sep 16, 2001 (gmt 0)

Brett:
Telnet: No, that's another catch. I read I could do that way, but I've never used Telnet. Downloaded a telnet app, tried to hook up, but failed here, too (oh, what a day. Will probably fail to pick my nose, too...)

Macguru:
Sorry, didn't want to do this on the sly. Thought it was too trivial for most viewers here (I truly feel like a dork).
Whether I have access to error log files? I suppose you mean the log files for this particular app? Well, I don't know (and now I'm getting all scarlet).

Slade:
I'm sure you mean well. But you'll have to talk to me as you're talking to a two-year old.

Anyways: I have uploaded screen shots from the config page with the four boxes that have to be filled out. Go to [weazeldicks.au.com...]

Check it out, and perhaps you understand...

Dan

john316




msg:362072
 5:41 pm on Sep 16, 2001 (gmt 0)

The answer is on the support page that is linked from the page you posted. This would be your server path to your cgi-bin when you replace the variables.

/www/full/first letter of your domain name/your domain name/cgi-bin/

Macguru




msg:362073
 5:43 pm on Sep 16, 2001 (gmt 0)

Hi again Dan_Titan,

Excuse my English, still having free lessons here, :)

Welcome to WMW this place is for all of us, I also feel like a dork for some issues here, so don't turn scarlet yet. I believe You get some ftp acces for your remote server?

Wath software do you use to tansfer files to this server?

Macguru




msg:362074
 5:46 pm on Sep 16, 2001 (gmt 0)

Hi again Dan_Titan,

Stick to what john316 wrote you. He beat me on speed. If any questions, do not hesitate.

Hope to see you soon again.

Dan_Titan




msg:362075
 5:48 pm on Sep 16, 2001 (gmt 0)

Guys!
I've tried that recommended path from the hosts page about a zillion times. No luck...

Macguru:
Yes, I have FTP access.
I'm using either Fetch or Transmit for single files, and DW4 when I'm synchronizing...

On Mac...

(edited by: Dan_Titan at 5:53 pm (gmt) on Sep. 16, 2001)

Macguru




msg:362076
 5:52 pm on Sep 16, 2001 (gmt 0)

OK, So can you anwser the questions in previous message?

Dan_Titan




msg:362077
 5:58 pm on Sep 16, 2001 (gmt 0)

Macguru:
See above. Can you figure something out?

Macguru




msg:362078
 6:10 pm on Sep 16, 2001 (gmt 0)

Ok, nice!

So in the server www root level of fetch do you see any folder named "stats", "logfiles" or something related?

If any, you will have error log files wich are plain text documents. Download it, open it and for some server errors you will get the full server path. It will look like this:

[12/Sep/2001:02:43:56] warning ( 8358): for host XXX.XXX.XXX.XXX trying to GET /XXX.htm, send-file reports: can't find "/XXX/XXX/XXX/XXX/XXX.htm (File not found) The stuff in bold is your full path name minus root or cgi-bin.

Dan_Titan




msg:362079
 6:50 pm on Sep 16, 2001 (gmt 0)

Macguru,
Be prepared; it's a bonehead at this end...
Have directories "stats" and "logs".
In the first are the HTML files I see when accessing the sitestats.
In the latter, there are four files (my digits first):
1) .processed (which is empty)
2) access.log (a 2.7Mb file with logs. I have searced through for a string as you describe, but found none)
3) lock (haven't even opened that one)
4) report.bd (no string as you describe)
5) access.log 20010904.gz (which is a log similar to the other access log.)

I'd be surprised if that info helps.

This morning (in Sweden) I mailed the hosts techs. But since they're in Australia, the time difference makes correspondence very slow.

However, if you like to check in to this directly (accessing the FTP), I'm not afraid of giving you the pass/log.

But since I don't want to have that in public, mail me at vendel@vendelcommunications.com

Dan

littleman




msg:362080
 7:12 pm on Sep 16, 2001 (gmt 0)

Load up this script where your other scripts sit and then call it in your browser.

#!/usr/bin/perl
print "Content-type: text/html\n\n";
$pwd = `pwd`;
print $pwd . "\n";

That will give you your path, don't forget to chmod it 755.

Dan_Titan




msg:362081
 7:41 pm on Sep 16, 2001 (gmt 0)

OK Littleman!
That was one hurdle...
Got the path the way you suggested. Phew. Tucked it into the boxes at the config. It appeared to do the trick. Because now, I don't get this Error message, but a kind of confirmation or clearance that it's all set.
But now it's a new problem. I'm supposed to point to a specific URL (http://www.weazeldicks.au.com/cgi-bin/mb/view.pl). But no matter how I upload the "view.pl" (ASCII, 777 or 755) it won't open!
And my little brain cell is about to have a meltdown.
Any more ideas?

Dan

dwedeking




msg:362082
 8:50 pm on Sep 16, 2001 (gmt 0)

Try changing it to a .cgi instead of .pl Some servers are configured to run the .cgi

Dan_Titan




msg:362083
 9:06 pm on Sep 16, 2001 (gmt 0)

When uploading as ASCII and 755 or 777, I get this when pointing to the page:
An error has occured
The error is Unable to open the dir for reading
Reason: No such file or directory

When uploading in non-ASCII mode, I get this:
Error 500 Internal Server Error

When changing to .cgi, I also get:
Error 500 Internal Server Error

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / WebmasterWorld / Webmaster General
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved