homepage Welcome to WebmasterWorld Guest from 54.166.159.110
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Code, Content, and Presentation / Flash and Shockwave
Forum Library, Charter, Moderator: open

Flash and Shockwave Forum

    
Flash Movie Problems
Flash is Interfering with drop down menu
Llana1976

5+ Year Member



 
Msg#: 3485459 posted 8:42 pm on Oct 23, 2007 (gmt 0)

I am working on a new front page for my website. At the top of my page I have a Nava bar with 5 links across it. When you hover over the Nava bar on one of the links a drop down menu will appear. Well here's the problem, I have inserted a flash movie clip in a table below the Nava bar. Now the Nava bar drop down menu works but it is showing up behind the flash movie clip. How do I get it to show up in front of the movie clip. Know one will be able to see the drop down menu because of the flash movie clip.

Does anyone have any advice?

 

phranque

WebmasterWorld Administrator phranque us a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month



 
Msg#: 3485459 posted 1:53 pm on Oct 24, 2007 (gmt 0)

welcome to WebmasterWorld, Llana1976!
(thanks for delurking)

this is probably the wmode transparency bug.
try using the swfobject javascript solution.

walrus

10+ Year Member



 
Msg#: 3485459 posted 3:23 pm on Oct 24, 2007 (gmt 0)

Not sure if this will work but....if you are using CSS you can set the z-index: value to have one appear over the other.

phranque

WebmasterWorld Administrator phranque us a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month



 
Msg#: 3485459 posted 11:10 pm on Oct 24, 2007 (gmt 0)

if you are using CSS you can set the z-index

if you do a search on "wmode transparency bug" i'm sure you will find plenty of references to the fact that this does not work properly.

walrus

10+ Year Member



 
Msg#: 3485459 posted 4:10 pm on Oct 25, 2007 (gmt 0)

hehe, hence the disclaimer intro, thanks for the clarification.

Achernar

5+ Year Member



 
Msg#: 3485459 posted 4:49 pm on Oct 25, 2007 (gmt 0)

Check this thread:
[webmasterworld.com...]

Llana1976

5+ Year Member



 
Msg#: 3485459 posted 6:14 pm on Oct 26, 2007 (gmt 0)

Thanks for the help I got it to work. New problem, can't get the flash to load in netscape browser. Have any ideas on this one.

Thanks
llana

Achernar

5+ Year Member



 
Msg#: 3485459 posted 9:58 pm on Oct 26, 2007 (gmt 0)

Verify the syntax of the <embed> tag. <embed ...> is for mozilla and <param ...> are for IE.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / Flash and Shockwave
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved