homepage Welcome to WebmasterWorld Guest from 54.198.130.203
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member
Home / Forums Index / Code, Content, and Presentation / Apache Web Server
Forum Library, Charter, Moderators: Ocean10000 & incrediBILL & phranque

Apache Web Server Forum

    
Need Help Configuring Virtual Host
Trouble with VirtualHost
redneckradioman




msg:4621940
 10:25 pm on Nov 7, 2013 (gmt 0)

Why does my server quit working every time I uncomment
# Include conf/extra/httpd-vhosts.conf? I'm Using Vertrigo 2.29 which is a stack that uses Apache 2.23 on windows 7 os

 

lucy24




msg:4621949
 11:11 pm on Nov 7, 2013 (gmt 0)

Preliminary question that you forgot to answer: does conf/extra/httpd-vhosts.conf physically exist in the (relative) location specified? (You are infuriated by the technician asking if your washing machine is plugged in ... until the day you go to check and Oh. Oops. Never mind then!)

phranque




msg:4621956
 11:32 pm on Nov 7, 2013 (gmt 0)

welcome to WebmasterWorld, redneckradioman!


have you checked the server error log for clues?

redneckradioman




msg:4622058
 4:07 pm on Nov 8, 2013 (gmt 0)

Yes lucy24 it is located there and I added my site info to it there. Yes phranque I did that in the hopes of getting a clue to what was going on but nothing there. Any help I would be thankful for.

lucy24




msg:4622149
 9:55 pm on Nov 8, 2013 (gmt 0)

Next diagnostic test: Comment-out the entire content of the file to be included-- but not the line that calls the include. Does the server still crash? First step is to work out if it's the act of inclusion or the content of the file that's causing trouble.

Does "quit working" mean that the server physically shuts down, that it plays dead, or simply that it throws a 500 error on all requests?

redneckradioman




msg:4622180
 11:30 pm on Nov 8, 2013 (gmt 0)

Thanks that was revealing it turns out
Use name-based virtual hosting.
/etc/httpd/conf/extra/httpd-vhosts.conf were uncommented in
/etc/httpd/conf/extra/httpd-vhosts.conf file


But now I'm getting 403 error on both primary and decondary site

below is how I formatted the directives

<VirtualHost *>example1.com>
ServerName example1.com
ServerAlias www.example1.com
DocumentRoot "C:/Program Files (x86)/VertrigoServ/www
DirectoryIndex index.html index.php
</VirtualHost>

<VirtualHost *>example2.com>
ServerName example2.com
ServerAlias www.example2.com
DocumentRoot "C:/Program Files (x86)/VertrigoServ/www/example2.com"
DirectoryIndex index.html index.php
</VirtualHost>

[edited by: phranque at 12:26 am (utc) on Nov 9, 2013]
[edit reason] no specifics please [/edit]

lucy24




msg:4622195
 2:05 am on Nov 9, 2013 (gmt 0)

Do you mean, 403 response to all requests all the time? At this point you really should be able to glean some information from error logs. The information may turn out to be "request denied by server configuration" (probably the #1 most unhelpful error message in all of Apache) but let's start there.

phranque, does it really say
<VirtualHost *>example2.com>
with mysterious extra > or was that an artifact of editing?

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / Apache Web Server
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved