homepage Welcome to WebmasterWorld Guest from 54.196.62.23
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Pubcon Platinum Sponsor 2014
Home / Forums Index / Code, Content, and Presentation / Apache Web Server
Forum Library, Charter, Moderators: Ocean10000 & incrediBILL & phranque

Apache Web Server Forum

    
Apache processes doing nothing randomly
Tommiiee



 
Msg#: 4616687 posted 6:38 pm on Oct 14, 2013 (gmt 0)

Hi all,

I have a problem with my web server. It's running 3 websites, but for some reason on random moments it's like it's shut down.

It disappears from the 'top' view, but when I use 'ps aux | grep httpd' it shows all 20 httpd processes. They're just not doing anything so my websites aren't working.

The CPU load is fine, RAM is fine (~80MB free), but for some reason it keeps doing this.

The error log doesn't show anything. Sometimes it shows 'MaxClients reached', but it shouldn't stop server my websites because of that.

MaxClients is set to 20 and ServerLimit is set to 150. Apache is running in prefork.

Is anybody able to help me solve this problem? Today was one of the worst days. I've just restarted apache for the 7th(!) time today..

Thanks,

Tom

 

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / Apache Web Server
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved