homepage Welcome to WebmasterWorld Guest from 54.227.34.0
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Code, Content, and Presentation / Apache Web Server
Forum Library, Charter, Moderators: Ocean10000 & incrediBILL & phranque

Apache Web Server Forum

    
Redirect not working in Test environment
mcjohnson

10+ Year Member



 
Msg#: 3933426 posted 11:04 am on Jun 15, 2009 (gmt 0)

I am attempting to redirect products from the old ecommerce website to the new. The new is on a different host and the nameservers have not yet been changed.

Hence, I have modified my hosts file to allow my browser to "see" the new website. I have added a 30 redirect to the .htaccess file for each product (as such)

Redirect 301 /catalog/vortex_tubes.php [mysite.com...]

but when testing, it simply gives me a page not found error on the new site.

My syntax is correct. Would there be any reason this wouldn't test out properly?

 

g1smd

WebmasterWorld Senior Member g1smd us a WebmasterWorld Top Contributor of All Time 10+ Year Member



 
Msg#: 3933426 posted 12:14 pm on Jun 15, 2009 (gmt 0)

The test is successful if the redirect forces the URL shown in the browser URL bar to change from the old URL to the new URL.

This does not depend on the new URL returning a valid page or not. That's another step, and not dependent on the redirect.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / Apache Web Server
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved